Arrrr j'en peux plus :p

6 posts / 0 new
Dernière contribution
MasterSleepy
Arrrr j'en peux plus :p

Salut,

cela fait 5 heures que j'essaye de faire fonctionner opengroupware...

J'ai suivi les 2 howto (postgreSQL et opengroupware) jusqu'au bout, je les ai même refait 2 fois chacun et j'ai toujours le même problème :

la page de opengroupware s'affiche et j'ai juste ce message :

The SKYRIX application server could not connect to the database server !

Please ensure that your database server is running and that the LSConnectionDictionary default is correctly set.

--------------------------------------------------------------------------------
Current database configuration:
database: missing
server: missing
user: missing

Pourquoi me dit-il que ces paramètres sont "missing" alors qu'ils sont correctement renseignés ?

J'ai écumé tous les newsgroups, apparemment l'erreur classique est sur le nom de la machine à mettre dans le Defaults. Malheureusement j'ai tout essayé !

Je ne vois plus de solution, j'en ai raz-le-bol pour ainsi dire, et tant pis j'avais décidé de ne pas y aller, mais j'y vais quand même à ma soirée Beaujolais du foot Wink

Merci de m'aider si vous pouvez.

@+

Migration writed for esteban

MasterSleepy
Arrrr j'en peux plus :p

Salut,

Apparemment, la base de donné n'est pas renseigné pour l'utilisateur opengroupware.
Dans le howto à l'étape 5, il faut renseigner plusieurs variables nécessaire pour le bon fonctionnement de opengroupware.
La ligne qui suit :
# Defaults write NSGlobalDomain LSConnectionDictionary '{databaseName = ogo; hostName = [hostname]; password = ""; port = 5432; userName = ogo}'
est en faite une seule commande Wink
Maintenant pour vérifier que toutes les commandes sont correctement entré :
Defaults read

avec l'utilisateur opengroupware, cela te donnera le résultat :
{
Defaults = {};
NSGlobalDomain = {
LSAdaptor = PostgreSQL72;
LSAttachmentPath = "/usr/lib/opengroupware.org/documents";
LSConnectionDictionary = {
databaseName = ogo;
hostName = slptest;
password = "";
port = 5432;
userName = ogo;
};
LSModel = "OpenGroupware.org_PostgreSQL";
LSModelName = "OpenGroupware.org_PostgreSQL";
LSNewsImagesPath = "/usr/lib/opengroupware.org/news";
LSNewsImagesUrl = "/ArticleImages";
Languages = (
English
);
NGBundlePath = "/usr/lib/opengroupware.org/Library/OpenGroupware.org";
TimeZoneName = MET;
XMLReader = libxmlSAXDriver;
};
}

Voilà, j'éspère que cela pourra t'aider

bonne soire beaujolais, tu me diras si il est bon Blum 3

A+

Migration writed for MasterSleepy

MasterSleepy
Arrrr j'en peux plus :p

Salut,

j'ai fait particulierement attention a ces détails et le résultat de Defaults read :

{
Defaults = {};
NSGlobalDomain = {
LSAdaptor = PostgreSQL72;
LSAttachmentPath = "/usr/lib/opengroupware.org/documents";
LSConnectionDictionnary = {
databaseName = ogo;
hostName = localhost;
password = "";
port = 5432;
userName = ogo;
};
LSModel = "OpenGroupware.org_PostgreSQL";
LSModelName = "OpenGroupware.org_PostgreSQL";
LSNewsImagesPath = "/usr/lib/opengroupware.org/news";
LSNewsImagesUrl = "/ArticleImages";
Languages = (
English
);
NGBundlePath = "/usr/lib/opengroupware.org/Library/OpenGroupware.org";
TimeZoneName = MET;
XMLReader = libxmlSAXDriver;
};
}

Ca devrait etre bon sachant que ma machne s'appele GrandCondor et que j'ai le fichier hosts suivants :

127.0.0.1 localhost
192.168.201.1 GrandCondor.tibsys.com GrandCondor

...l'interrogation de postgreSQL fonctionne correctement...

Je ne vois pas ce qui ne fonctionne pas... Y a-t-il des choses que je devrait vérifier en particulier ?

Sinon ma soirée Beaujolais se termine juste... je pars pour soirée d'un autre genre, alors à demain

Merci pour ton aide.

Esteban

Migration writed for esteban

MasterSleepy
Arrrr j'en peux plus :p

Salut,
Il y a qd mm un truc que je trouve bizarre,
Dans ton premier message il marque qu'il n'a aucun information pour ce connecter à la base de donnée.
Etrange car le résultat de que t'a affiché en dessous à l'air correct, apart le hostname qui devrait être, dans ton cas, GrandCondor.

[quote:395bfeaa2e]Salut,

j'ai fait particulierement attention a ces détails et le résultat de Defaults read :

{
Defaults = {};
NSGlobalDomain = {
LSAdaptor = PostgreSQL72;
LSAttachmentPath = "/usr/lib/opengroupware.org/documents";
LSConnectionDictionnary = {
databaseName = ogo;
hostName = localhost;
password = "";
port = 5432;
userName = ogo;
};
LSModel = "OpenGroupware.org_PostgreSQL";
LSModelName = "OpenGroupware.org_PostgreSQL";
LSNewsImagesPath = "/usr/lib/opengroupware.org/news";
LSNewsImagesUrl = "/ArticleImages";
Languages = (
English
);
NGBundlePath = "/usr/lib/opengroupware.org/Library/OpenGroupware.org";
TimeZoneName = MET;
XMLReader = libxmlSAXDriver;
};
}

Ca devrait etre bon sachant que ma machne s'appele GrandCondor et que j'ai le fichier hosts suivants :

127.0.0.1 localhost
192.168.201.1 GrandCondor.tibsys.com GrandCondor

...l'interrogation de postgreSQL fonctionne correctement...

Je ne vois pas ce qui ne fonctionne pas... Y a-t-il des choses que je devrait vérifier en particulier ?

Sinon ma soirée Beaujolais se termine juste... je pars pour soirée d'un autre genre, alors à demain

Merci pour ton aide.

Esteban [/quote]

Migration writed for MasterSleepy

MasterSleepy
Arrrr j'en peux plus :p

AYE G REUSSI !!

tu vas rire... moi j'en ris toujours (jaune biensur)

Dans les Defaults j'avais fait une faute : j'avais mis LSConnectionDictionnary (avec 2n à Dictionnary) au lieu de Dictionary !!!!!!!

Smile

Migration writed for esteban

MasterSleepy
Arrrr j'en peux plus :p

Ahhh ben ça alors ça me rassure.
Bien je te comprends c'est chiant de ramer sur un truc pareil.

Allez une bonne nouvelle, cool ça.
Bonne continuation avec opengroupware.

Migration writed for MasterSleepy

Connectez-vous ou inscrivez-vous pour publier un commentaire