Pb avec les templates

5 posts / 0 new
Dernière contribution
MasterSleepy
Pb avec les templates

Bonjour,

Biggrin

Alors voila mon problème:

Je veux accomoder le rpm de HaM (qu'il a creer, avec une personne que je ne citerais pas Wink , un rpm pour FREEEOS, donc SME 5.5), a ma souce afin qu'il fonctionne sous sme 6.0.1.

Rapidement, pour mettre en place le sujet...
Ce rpm permet de realiser des sauvegardes (journaliere, hebdo...etc...)
Il travaille donc avec Crond.
Afin, de mette a jour le fichier /etc/crontab, il y a dans "/etc/e-smith/events/actions/bachupcustom_config_crontab" une belle generation de template (je crois que c'est ça), mais la template ne met pas à jour le fichier /etc/crontab donc pas de lancement de la tache!!

Il me faut faire un "/sbin/e-smith/expand-template /etc/crontab" puis un "service crond restart", pour que cela fonctionne, d'ou ma question (on y arrive).

Comment ajouter dans les 2 commandes précedentes ou leur equivalent pour que cela fonctionne?

Merci

Argenlos

Migration writed for argenlos

MasterSleepy
Pb avec les templates

Salut Argenlos,

Je pense que le problème vas être résolu ce week-end.
Ce problème viendrait de celui qui a fait l'interface Wink
NON NON NON je ne balancerai pas que c'est moi qui l'ai faite. :hot: :hot: :hot:

A+

Migration writed for MasterSleepy

MasterSleepy
Pb avec les templates

Bonjour MasterSleepy,

Donc, il y avait bien un chiml'blic...

Je serais content de voir comment cela va être résolut, car en ajoutant dans "/etc/e-smith/events/actions/bachupcustom_config_crontab", les lignes suivantes ça veux pas marcher:

exec("/sbin/e-smith/expand-template /etc/crontab");
puis
exec("service crond restart");

J'ai regarder comment etait "fabriqué" les autres fichiers du même répertoire, et bien je ne vois pas.

Je vais chercher encore une petit peu, mais j'ai passé un bon moment déja dessus...et je ne vois pas.

Bon courage, et bravo encore :clap: C'est joliement fait. :clap:

[Edité le 26/3/2004 par argenlos]

Migration writed for argenlos

MasterSleepy
Pb avec les templates

Bonjour, a propos de se petit pb, j'ai peut etre une solution, "tordu" mais qui fonctionne Wink

[quote:a6caba478d]
Résolution du bug: (qui entraine le non fonctionnement de l'appli, qui était pas de lancement de la tâche)

1:
on enleve le lien symbolique S10Backup_conf qui est sous "/etc/e-smith/events/backupcustom_conf"
(donc l'utilité du fichier "backupcuston_config_crontab" est nulle)

2: on crée un lien symbolique:

[root@smesave root]# ln -s /etc/e-smith/events/actions/restart-crond /etc/e-smith/events/backupcustom_conf/S20Backup_conf

(relance du service crond, restart-crond existe déjà)

3:
on édite le fichier "/etc/e-smith/web/functions/backupcustom"

on recherche la fonction "changeValue" (avant dernière), et on ajoute ceci, jeste AVANT "return;"

#creation template plus reance crond
system ("/sbin/e-smith/expand-template /etc/crontab") == 0 or die ("Pb lors creation template.\\n");
esmith::util::backgroundCommand (8, "/sbin/e-smith/signal-event", "backupcustom_conf");

[/quote]

Voila , J'entend d'ici MasterSleepy qui me dit: "c'est pas comme cela que ça doit etre fait!".

Cordialement,

Argenlos

Migration writed for argenlos

MasterSleepy
Pb avec les templates

Salut,

Elle n'a pas l'air si tordue que ça ta soluce.
Je dirais même plus, :super: :super: :super:

A+

Migration writed for MasterSleepy

Connectez-vous ou inscrivez-vous pour publier un commentaire