phpsysinfo & awstat

6 posts / 0 new
Dernière contribution
MasterSleepy
phpsysinfo & awstat

Bonjour à tous.

Je préfère m'excuser car mon niveau sous linux, est vraiment au stade de débutant. j'avais commencé à installer une debian et alternc, mais vraiment trop compliqué pour moi Smile
Je me suis rabattu sur SME qui est d'une simplicité d'installtion et d'utilisation.

J'utilise une contrib SME Server 6.0.1-01, et j'ai installé récement phpsysinfo 2.2, je me suis apercu que ma Mémoire Physique est rarement en dessous de 95% et que le swap est à 4%
Je voudrais savoir si cela est normal ? et si cela vient du pc ou d'un autre problème ?

Infos du serveur

Et enfin, j'ai suivi l'installation pour awstats sur le site : http://www.batosai.net/howto-awstats.php, mais j'ai un problème avec le lancement de la mise à jour automatique toutes les heures .
A priori le pc 'mouline' toutes les heures pleines, mais en consultation la mise a jour ne se fait pas.
Pourtant j'ai fait les cmds en root
crontab -e
0 * * * * /home/e-smith/files/primary/cgi-bin/awstats.pl -config=www.votresite.com -update &> /dev/null

Merci d'avance et encore toutes mes excuses pour ces questions qui sont surement évidentes.

PS: y a t'il un pakage pour gérer des mailing list pour la version que j'utilise de sme ? Merci

Cordialement Gilles.

[Edité le 8/6/2004 par promoweb[gilles]]

[Edité le 8/6/2004 par promoweb[gilles]]

Migration writed for promoweb[gilles]

MasterSleepy
phpsysinfo & awstat

Salut Gilles,

Pour ce qui est de la mémoire utilisé sur ton serveur c'est tout à fait normal.
En général certains service style "apache" prenne le plus de mémoire disponible.
Donc tu rajouterais de la mémoire ce serait pareil.

Pour awstats, as-tu essayé de lancer la commande à la main??
Essaye de lancé cette commande :
/home/e-smith/files/primary/cgi-bin/awstats.pl -config=www.votresite.com -update

Et il t'affichera les messages d'erreurs à la console.

A+

Migration writed for MasterSleepy

MasterSleepy
phpsysinfo & awstat

Merci de ton aide :

J'ai lancé la commande et a priori il n'affiche pas de message d'erreur (enfin ca à pas l'air) :

Update for config "/home/e-smith/files/primary/cgi-bin/awstats.conf"
With data in log file "/var/log/httpd/access_log"...
Phase 1 : First bypass old records, searching new record...
Direct access after last updated record successfull (after line 1875)
Phase 2 : Now process new records (Flush history on disk after 20000 hosts)...
Jumped lines in file: 1875
Found 1875 old records.
Parsed lines in file: 61
Found 1 dropped records,
Found 0 corrupted records,
Found 0 old records,
Found 60 new qualifed records.

D'ailleurs en manuel cela marche sur l'url précédement citée .
MAis dès que je passe la ligne dans la crontab pas de mise a jour.

Merci encore MasterSleepy

Migration writed for promoweb[gilles]

MasterSleepy
phpsysinfo & awstat

Bonjour à tous,

Juste une dernière question (excusez moi) ,
Quand je lance : crontab -e sous root

j'obtiens un message avant d'arriver dans vi pour l'édition .
Voici ce message :
Error detected while processing /root/.vimrc:
line 81:
E319: Sorry, the command is not available in this version: filetype on
line 83:
E319: Sorry, the command is not available in this version: filetype indent on
line 85:
E319: Sorry, the command is not available in this version: syn on

Cela est peut être la cause de mon problème de réactualisation de awstats ? car en manuel il marche parfaitement.

J'aimerais bien le faire marcher via cron .

Merci beaucoup à tous.

Migration writed for promoweb[gilles]

MasterSleepy
phpsysinfo & awstat

Salut,

Vlà seulement que je percute je suis vraiment un :ane:

Un autre truc à essayer, plutôt que de faire ça avec crontab -e
utilise plutôt le répertoire /etc/cron.d

Crée un fichier dans ce répertoire, ce fichier contiendra


*/15 * * * * root /home/e-smith/files/primary/cgi-bin/awstats.pl -config=www.votresite.com -update &> /dev/null



Avec cette manip la mise à jour ce fera toutes les 15 min.

Maintenant pour ton prob avec l'éditeur vi, essaye d'effacer le fichier /root/.vimrc
Apparement il y a des commandes dedans qu'il ne comprends pas.

Aussi avant que je n'oublie, enlève la ligne que tu as rajouté avec crontab -e

A+

Migration writed for MasterSleepy

MasterSleepy
phpsysinfo & awstat

Non non ce n'est pas toi qui est :ane: c'est moi qui suis un :thumbdown: :ane: lol .

Le problème vient du path ver l'ibays .. arf' (je suis nul) !

Avant : /home/e-smith/files/primary/cgi-bin/awstats.pl -config=www.votresite.com -update &> /dev/null

Après : /home/e-smith/files/ibays/Pimary/cgi-bin/awstats.pl -config=www.votresite.com -update &> /dev/null

PAr contre pour les erreurs je comprends pas , mais cela marche.

Milles excuses. (je vérifirais 12 fois avant de poster) ..

Merci de ta patience Master

Bonne journée à tous.

Migration writed for promoweb[gilles]

Connectez-vous ou inscrivez-vous pour publier un commentaire