LOOL sur sme server 8

7 posts / 0 new
Dernière contribution
MasterSleepy
LOOL sur sme server 8

Bonjour,

Tour d'abord, je suis très content de faire parti des membres de ce site qui m'a initié à l'administration de SME Server. Wink

J'essai d'installer Open Office On Line sur la sme server 8.

Voici ma démarche :

- 1, après l'installation de sme server 8 en mode application, je lance une mise à jour du système :

yum update

une fois terminé, je redémarre la sme :

signal-event post-upgrade; signal-event reboot

- 2, j'installe git comme décrit sur le site contrib soit :

/sbin/e-smith/db yum_repositories set through-ip repository BaseURL http://through-ip.com/packages/smeserver/i386/ Name 'Through IP Pty. Ltd.' EnableGroups yes Visible yes GPGCheck no status disabled

signal-event yum-modify

yum --enablerepo=through-ip --enablerepo=dag install smeserver-git smeserver-gitweb smeserver-gitweb-theme

-3, je lance le téléchargement de LOOL en suivna tla procédure du site Libre Office :

git clone http://anongit.freedesktop.org/git/libreoffice/core.git

-4, je lance dans le dossier core le fichier d'installation :

./autogen.sh

Faute de dépendence, j'installe les éléments suivants :

-5, un compileur C

yum --enablerepo=smecontribs install gcc

-6, le serveur d'impression

yum install cups-devel

une fois terminé, je relance le autogen.sh

voici le message d'erreur que je rencontre :

error: Package requirements (fontconfig >= 2.2.0) were not met:

No package 'fontconfig' found

donc le programme d'installation ne trouve pas fontconfig !!

ce qui est étonnant car en lançant la commande :

yum info fontconfig

j'obtient :

Installed Packages
Name : fontconfig
Arch : i386
Version : 2.4.1
Release : 7.el5
Size : 361 k
Repo : installed

l'installation de LOOL se bloque et moi aussi :-?

Si jamais vous pouvez m'aiguiller...

Migration writed for baptiste

MasterSleepy
LOOL sur sme server 8

Salut,

J'ai trouvé cette article:
http://lists.freedesktop.org/archives/libreoffice/2011-June/013958.html

Dans le premier post, il est conseillé d'initialiser deux variables d'environement: FONTCONFIG_CFLAGS et FONTCONFIG_LIBS.

C'est a essayé.
J'essaye l'install en ce moment mais depuis les tar pour m'eviter l'install de git Wink

Si je trouve d'autre info, je te tiendrai au courant.

A+,
MasterSleepy.

Migration writed for MasterSleepy

MasterSleepy
LOOL sur sme server 8

Salut,

Bon, j'avance doucement.
Pour l'histoire des font, il suffit d'installer fontconfig-devel:

yum install fontconfig-devel


Après c'est des modules de Perl qui manque.

Je continue et te tiens au courant.

++
MasterSleepy

Migration writed for MasterSleepy

MasterSleepy
LOOL sur sme server 8

VOILA!!!!!

pffff, ce fut rude.
Voici tout ce que j'ai du faire pour finir le autogen.sh

Il y fallu installer une librairie perl

# perl -MCPAN -e shell
cpan> i /archive::zip/

install Archive::Zip
quit


Ensuite j'ai du installé beaucoup de dépendance

yum install gcc-c++
yum install java
yum install java-devel
yum install gperf
yum install libjpeg-devel
yum install libxslt-devel
yum install libX11-devel
yum install libXrandr-devel
yum install xorg-x11-xtrans-devel
yum install libXt
yum install libXt-devel
yum install libXrender-devel
yum install bison
yum install flex



Le pire est à venir ...
Le problème suivant venait de ZIP :boah: qui n'était pas en version 3 ou supérieur.
Comme j'était sur le point de tout effacer, j'ai téléchargé le source depuis le site
http://sourceforge.net/projects/infozip/develop?source=navbar
Je l'ai décompressé et compilé


tar -xvzf .......
cd ....
make -f unix/Makefile generic


Après comme j'en avais marre, j'ai simplement remplacé les éxécutables existants par ceux compilé.

Après, j'ai ENCORE installé des dépenances:

yum install GConf2 GConf2-devel
yum install gnome-vfs2 gnome-vfs2-devel
yum install gstreamer gstreamer-devel
yum install gstreamer-plugins-base gstreamer-plugins-base-devel
yum install libGLU libGLU-devel
yum install ant


Et maintenant ca fonctionne avec la commande suivante:

./autogen.sh --disable-gtk --without-junit


Bon maintenant ca compile, et j'ai 3 milliards de message d'erreurs qui apparaissent, donc surement bon signe Lol

A+,
MasterSleepy.

Migration writed for MasterSleepy

MasterSleepy
LOOL sur sme server 8

Salut et merci pour l'interêt porté à mon projet.

En tout cas, on peut dire qu'il porte bien son nom celui la !!
LOOL ou comment faire pour se casser les neurones Secret

Suite aux solutions que tu as donné,

j'ai commencé par la partie facile (installer toutes les dépendences que tu as cité)
et 2 dépendences de plus comme trouvé sur ce tuto pour CentOS 5 car le GTK3 est dans les prérequis.

J'ai bloqué un moment sur l'installation du module perl
j'ai lancé les commandes conseillés depuis le dossier root (je en sais pas si ca a son importance)
Même après le lancement des commandes du module Perle Archives Zip, j'obtient tounours la même erreur :

Can't locate Archive/Zip.pm

du coup, j'ai recopié le contenu du dossier /root/perl/lib/perl5 dans le dossier /usr/lib/perl5
C'est à l'arrache mais ca a fonctionné

je ne vois pas pourquoi l'installation a foiré.

Bref j'arrive au problème du ZIP !!

je l'ai téléchargé en version ZIP30
l'ai décompressé et ai remplacé le fichier zip de sme :

cp zip /usr/bin

et la miracle, l'autogen arrive au bout

Donc a part l'installation du module perl, tout a fonctionné comme tu l'as dit (Encore merci)

Après, j'ai lancé un make check suivi d'un make dev-install

et j'obtient une erreur à l'étape 8 sur 9 :

../../lib/libicuuc.so: undefined reference to `__sync_val_compare_and_swap_4'
../../lib/libicuuc.so: undefined reference to `__sync_add_and_fetch_4'
../../lib/libicuuc.so: undefined reference to `__sync_sub_and_fetch_4'
collect2: ld a retourné 1 code d'état d'exécution
make[4]: *** [../../bin/makeconv] Erreur 1
make[3]: *** [all-recursive] Erreur 2
make[2]: *** [all-recursive] Erreur 2
make[1]: *** [/root/core/workdir/unxlngi6.pro/ExternalProject/icu/build] Erreur 1

-----------------------------------------------------------------------
Oh dear - something failed during the build - sorry !
For more help with debugging build errors, please see the section in:
http://wiki.documentfoundation.org/Development

internal build errors:

ERROR: error 512 occurred while making /root/core/tail_build/prj

it seems that the error is inside 'tail_build', please re-run build
inside this module to isolate the error and/or test your fix.

-----------------------------------------------------------------------
To rebuild a specific module:

make tail_build.clean # not recommended, this will re-build almost everything
make tail_build

when the problem is isolated and fixed, re-run 'make'
make: *** [build-postprocess] Erreur 1

A priori plusieurs forums traitent de cette erreur lié à Gentoo
mais je ne trouve pas de solution pour fixer ou contourner cette erreur.

Je pense refaire l'installation depuis le début.

Je posterai le résultat si jamais j'arrive à faire mieux.

Baptiste.

Migration writed for baptiste

MasterSleepy
LOOL sur sme server 8

Salut,

pour avancer sur le dossier, j'ai essayé de procéder comme sur la procédure du site Libre Office.

db yum_repositories set epel repository \
Name 'Extra Packages for Enterprise Linux 5' \
MirrorList 'http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=i386' \
status disabled GPGCheck yes \
GPGKey http://download.fedora.redhat.com/pub/epel/RPM-GPG-KEY-EPEL
signal-event yum-modify

enuiste, j'ai installé la dépendence :

yum install yum-utils

pour lancer la commande yum-builddep libreoffice ,

yum-builddep --enablerepo=epel libreoffice

Cette commande est censé installer toutes des dépendences.

Merci de me dire si je fais quelque de travers.

Après lecture,

Cette commande est valable pour fedora 15 et + qui est basé sur RHEL6 et SME 8 sur RHEL5.

Je devrais peut être attendre la sortie de SME Server 9 basé sur Centos 6 pour utiliser cette commande

par contre, j'ai relancé ./autogen.sh sans message d'erreur

une fois terminé, j'ai lancé un make mais j'ai toujouts le même problème :

../../lib/libicuuc.so: undefined reference to `__sync_val_compare_and_swap_4'
../../lib/libicuuc.so: undefined reference to `__sync_add_and_fetch_4'
../../lib/libicuuc.so: undefined reference to `__sync_sub_and_fetch_4'
collect2: ld a retourné 1 code d'état d'exécution
make[4]: *** [../../bin/makeconv] Erreur 1
make[3]: *** [all-recursive] Erreur 2
make[2]: *** [all-recursive] Erreur 2
make[1]: *** [/root/core/workdir/unxlngi6.pro/ExternalProject/icu/build] Erreur 1

-----------------------------------------------------------------------
Oh dear - something failed during the build - sorry !
For more help with debugging build errors, please see the section in:
http://wiki.documentfoundation.org/Development

internal build errors:

ERROR: error 512 occurred while making /root/core/tail_build/prj

it seems that the error is inside 'tail_build', please re-run build
inside this module to isolate the error and/or test your fix.

-----------------------------------------------------------------------

Bref j'avance pas mais si je trouve, je posterai cela

Baptiste

Migration writed for baptiste

batist3
j'ai abandonné :( mais j'ai trouvé une autre solution !

l'idée de départ était de travailler sur une même base de fichiers consultable et modifiable en ligne.

les fichiers devaient être en ligne de manière a ne pas télescoper des révisons.

 

j'ai essayé Office Web apps (trop lourd)

libre office on line (pas abouti et pas installable sur SME)

 

du coup je me suis tourné vers un Synology avec le module Cloud Station.

les fichiers sont mis à dispo sur un NAS en SMB et synchronisé via internet et en lan via l'applicatif dédié.

Les fichiers sont recopiés sur  les postes dans un dossier dédié et synchronisé uen fois connecté àinternet.

l'applicatif fonctionne aussi bien sous Windows, Linux et Apple.

 

ils sont toutefois consultable via un navigateur internet par le biais d'une connexion SFTP et du module FireFTP de Firefox.

 

C'est pas tout à fait l'idée de départ mais cette solution est très efficace et d'une grande simplicité d'installation .

 

batist3

Connectez-vous ou inscrivez-vous pour publier un commentaire