Php Server Monitor sur SME

6 posts / 0 new
Dernière contribution
MasterSleepy
Php Server Monitor sur SME

Salut baptiste,

Merci beaucoup pour ce HowTo.

A+,
MasterSleepy.

Migration writed for MasterSleepy

batist3
Migration ou installation Version 3 sur SME Server 8

la version 3.0.0 fonctionne sous SME Server 8 mais la version 3.0.1 requiert php 5.3.7+

 

du coup j'ai du télécharger la v3.0.0., créer l'ibay,la base et l'utilisateur SQL

décompresser les fichiers et lancer l'installation via l'interface web.

 

Pour migrer la liste des serveurs d'une ancienne version, il suffit de sauvegarder la table pms_server et de la restaurer dans la nouvelle base SQL dans la même table.

il faudra supprimer toutes les lignes du dessus jusque INSERT INTO exclus et supprimer les 3 dernières lignes.

 

Si comme moi, vous devez fusionner plusieurs phpservermonitor,

il faut fusionner les différentes tables pms_server des bases SQL,

il faudra ne pas avoir deux fois les mêmes server_id

 

l'installation est alors terminée. la configuration se fait facilement via l'interface Web.

 

Pour la planification des vérifications,il faut exécuter ces commandes :

 
mkdir -p /etc/e-smith/templates-custom/etc/crontab
nano /etc/e-smith/templates-custom/etc/crontab/phpservermonitor

 

Ecrire ce texte :

 

#Execution Server Monitor toutes les 10 min
*/10 * * * * root /usr/bin/php /home/e-smith/files/ibays/monitor/html/cron/status.cron.php

 

Ctrl X
o
entrée

 

 
Puis lancer la commande :
expand-template /etc/crontab
 
enfin, pour vérifier si la prise en compte est effective, taper :
less /etc/crontab
 
Appyer sur page down pour défiler et q pour quitter l'interface less.
 
voila, si ça peut aider ...
batist3
MasterSleepy
Salut Batist3,

Salut Batist3,

 

Merci beaucoup pour ce retour.

 

Je me posais la question de savoir si la version 3.0.1 pouvait s'installer sur la version 9 de SmeServer.

Plutôt étonnant mais non.

Basé sur centos 6.5, la version de php incluse est 5.3.3.

Dommage faudra attendre Sme Server 10 Sad

 

A+,

MasterSleepy.

MasterSleepy
Salut Batist,

Salut Batist,

 

Je viens de tomber la dessus:

http://wiki.contribs.org/index.php?title=Upgrade_php/mysql#For_SME9

 

un guide pour passer à php 5.5, sur sme 9 pour le moment mais une version pour sme 8 à l'air d'être en préparation.

 

A+

MasterSleepy

batist3
petit up

Salut MasterSleepy,

 

Merci pour ces infos.

j'utilise ces outils en production du coup je reste sur les versions stables (Webapps & SME Server).

 

 

Par contre pour ceux qui veulent tester, la version de PhpServerMonitor 3.1.0 est sortie avant hier !

 

voici les précos :

 

* Web server
* MySQL database
* PHP 5.3.7+
* PHP cURL package
* PHP PDO mysql driver

 

La grosse différence entre la v2 et la v3 est l'historique, les statistiques des Monitoring.

 

batist3

Connectez-vous ou inscrivez-vous pour publier un commentaire