démararge service automatique

6 posts / 0 new
Dernière contribution
batist3
démararge service automatique

Bonjour,

 

Je cherche à démarrer automatiquement un service sous centos 6.7

J'arrive à le démarrer manuellement à chaque démarrage avec une commande /etc/init.d/xxxxx start

mais quand je tape la commande chkcon on, au redémarrage du serveur, celui ci ne se démarre pas.

 

je retrouve des liens vers ce service dans les dossiers /etc/rc.d/rc0.d jusque /etc/rc.d/rc6.d

 

Si quelqu'un a uen solution je suis preneur.

 

Merci d'avance et bonnes fêtes

batist3

MasterSleepy
Salut,

Salut,

 

Sous centos, j'utilise chkconfig pour configurer les services.

chkconfig --list

Va donner la liste de tous les services dispo et comment ils sont configurés:

Example:

httpd           0:arrêt 1:arrêt 2:arrêt        3:marche        4:marche        5:marche        6:arrêt
ip6tables       0:arrêt 1:arrêt 2:arrêt        3:marche        4:marche        5:marche        6:arrêt

Ensuite, pour les setuper

chkconfig service_name on --level 345

 

Bonnes fêtes,

MasterSleepy.

batist3
Salut,

Salut,

 

Merci pour cette réponse.

J'ai tapé la commande ci dessus et ai donc essayé la commande

chkconfig service_name on --level 2345

 

après redémarrage, j'ai toujours le même soucis.

Etrange...

 

j'ai également essayé d'ajouter la ligne

/etc/init.d/service_name start ou service service_name start dans le fichier /etc/rc.d/rc.local mais rien n'y fait

au démarrage le service est toujours arrêté.

 

idem pour le fichier rc.sysinit

 

du coup une fois redémarré, je dois aller sur la console pour lancer le service (qui une fois lancé fonctionne parfaitement)

 

bonne journée,

batist3

MasterSleepy
Hello Batist,

Hello Batist,

 

Curieux problème.

Une chose me vient en tête, n'y aurait-il pas un soucis avec les permissions?

Si tu lances le services étant connecter, ca fonctionne, mais pas quand c'est en automatique, c'est peut-être lié à un soucis avec l'utilisateur.

N'y aurait-il pas une trace dans les log?

 

Autre point:

Je testes en se moment, centos 7, et la je me rends compte que chkconfig ne fonctionne plus, il faut utiliser systemctl pour controler les services:

systemctl enable service_name

ou

systemctl disable service_name

 

Peut-être est-ce déjà présent dans la 6.7, essaye ca aussi?

 

A+,

MasterSleepy

batist3
Bonjour MasterSleepy,

Bonjour MasterSleepy,

 

A mon sens, le seul utilisateur existant est root

c'est une install minimale.

 

je viens d'essayer la commande systemctl sur la version 6.7 :

commande introuvable, j'avais testé la v7 et avait constaté de grandes différences sur les commandes

je suis donc resté sur la v6

 

A la limite, je vais essayer de réinstaller cet outil sur une installe propre et voir si le problème persiste.

je posterai la proc d'install si le problème se reproduit ça permettra peut êter de cibler la résolution.

 

En tout cas, merci pour les axes de recherches.

 

et au fait bonne année

Batist

batist3
Du coup, suite au post de l

Du coup, suite au post de l'installation du monitoring,

le serveur de test n'a pas le problème de lancement du service.

 

Suis un peu déçu... en même temps, c'est pas si grave mais bon

Connectez-vous ou inscrivez-vous pour publier un commentaire